Introduction to LTspice

This script introduces LTspice, a simulation tool for circuit analysis used in the electronics
courses at ZHAW.
Up to and including chapter 5the basic functions are explained. These chapters can be worked
through individually in 2 to 3 hours.
It is advised that you work through these chapters in the given order as necessary previous
steps are assumed in each example case and these steps are therefore not explained again.
Chapter 6collects special simulation elements, which are needed less often and serves as a
reference rather than belonging to the introduction.
All examples discussed can be found on the server http://dublin.zhaw.ch/~hhrt/LTspice/

Notice:
If a circuit works in the simulation, it is not yet guaranteed that the real design will work too.
Nevertheless, simulation is a time-saving tool when designing and later testing the real circuit.

 Hanspeter Hochreutener, hhrt@zhaw.ch , February 14, 2021. Translation: Mathis Nussberger
Institute of Signal Processing and Wireless Communications (ISC)
https://www.zhaw.ch/de/engineering/institute-zentren/isc/
School of Engineering https://www.zhaw.ch/de/engineering/
Zurich University of Applied Sciences http://www.zhaw.ch
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1. Install LTspice
Download LTspice free of charge from
http://www.analog.com/en/design-center/design-tools-and-calculators/ltspice-simulator.html
and install it. LTspice can, via WINE, also be used under Linux.
There is also a version for the Mac, the handling being slightly different.

1.1.

Library for ZHAW Electronics Lab

There is a symbols compilation and a library for the semiconductors used in the basic
electronics courses at ZHAW. Install both to follow this introduction.
•

Start LTspice and click on

¨
which creates a new schematic. Now click on

If you do not see this icon, you may have to enlarge the LTspice window horizontally.
In the component selection window take notice of the mentioned path, which will be different
than shown below in your case

•

Download the symbol file http://dublin.zhaw.ch/~hhrt/LTspice/Symbole.zip, unzip and copy it
to this directory: ….\sym\ZHAW.

•

Download the Spice library http://dublin.zhaw.ch/~hhrt/LTspice/ZHAW.lib and copy it to this
directory:…\lib\sub
Attention: The file name must be "ZHAW.lib"; "ZHAW.lib.txt" does not work. MS Windows
does not show you file extensions per default. Open an explorer window (shortcut windows
key – e), select the tab “Ansicht” and check the checkbox “Dateinamenerweiterungen”

Note: Do not use the browser "Chrome", because it changes the file content.
•

Restart LTspice, repeat the steps above up to the opening of the component selection
window. The folder ZHAW should now show up in this window.

1.2.

European Resistor

After installation, LTspice uses an anglo-american resistor symbol, here shown for resistor R1.
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If you like to generally use an european resistor symbol like the one shown for R2, proceed as
follows:
1. Open the folder C:\Users\***\Documents\LTspiceXVII\lib\sym (for the Mac and older
LTspice versions, see locations mentioned in Section 1.1)
2. Find the file "res.asy" and rename it to "res_us.asy".
3. Navigate to the folder C:\Users\***\Documents\LTspiceXVII\lib\sym\Misc
4. Copy the file "EuropeanResistor" to the "sym" folder (one level up)
5. Rename the copied file to "res.asy"
6. Restart LTspice. All circuits, even preexisting, will now use the european symbol. The
icon in the icon list below the menu list will not change, however.
7. By reversing these steps you can go back to the anglo-american resistor symbol at any
time.

2. Schematic Capture
The easiest way to learn how to draw the schematic of a circuit is to use an example. The
individual steps for a preamplifier with single-supply operational amplifier according to the
schematic below are demonstrated. You do not need to know anything about this circuit or its
components right now. In fact, you will find out what it does and which components are used by
executing the following exercises and study the explanations in between.

2.1.

Move, wire and delete components

These are the editing commands you need to draw the schematic:

LTspice introduction.docx

4/ 23

Hochreutener, SoE@ZHAW

(Edit => Rotate) to rotate a part before placing it.
Note: An already placed part must first be selected with Drag or Move.
(Edit => Mirror) to mirror a part before placing it.
Note: An already placed part must first be selected with Drag or Move.
(Edit => Drag) to move the part. Select the desired part or an entire area by left-clicking,
move it to the desired location and place it by left-clicking again. The wire connections are
dragged along.
(Edit => Move) does the same, but the wire connections are not pulled along.
(Edit => Place GND) connects to ground = 0 volts reference potential for simulation
(Edit => Draw Wire) connects components. Left-click at start of wire, change of direction
and end of wire.
(Edit => Delete) deletes connections and components. You can also use the mouse to
select an entire area to be deleted.
Right-click on a connection and Delete Net deletes the whole net and not just a wire
segment.
ESC key each time to end a function.
to enlarge, center, reduce and fit the schematic.

2.2.

Passive components
Exercise
Start LTspice and open an empty schematic by clicking the button
using the menu File => New Schematic.

on the toolbar or

Exercise
For the resistors click on the icon (

Menu Edit => Resistor).

Place the four resistors.
ESC key to exit.
Change resistance value with right-click on the letter R next to the icon

R overwrite with 220k, etc.
Similarly, the part name can be
customized by right-clicking on
the name.
For the numerical values, you can
use
these
engineering
abbreviations:
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Risk of confusion: "M" or "m" is milli = 10-3, "MEG" or "meg" is mega = 106
Exercise
Proceed in the same way for the capacitors: Icon (

Menu Edit => Capacitor).

Change capacitor value with right-click on the letter C next to the icon.
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2.3.

Active components

All components (even resistors and capacitors) can be obtained via the icon (
Component).

Edit =>

The square brackets denote folders with the more components.
Double click on [Opamps] shows the operational amplifiers from Linear Technology.
Back by double-clicking [...].
The [ZHAW] folder lists the semiconductors used in the basic electronics courses at ZHAW.
Exercise
Select the LMC6482 from the [ZHAW] folder and position it in the schematic.
Move, rotate and wire all components mentioned so far until the schematic looks
something like this (pay attention to the polarities of the LMC6482):

The voltage supply of the operational amplifier and the input signal are still missing, as well as a
dedicated output port.
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2.4.

Voltage and current sources with fixed values
Exercise
Select a voltage source via the icon ( Edit => Component) then select voltage. (For
a current source you would select current).

Right-click on V1 and change the name to Vsupply.
Right-click on V and type 3 (= 3 volts).

2.5.

Signal generators

The voltage and current sources described above can be configured to behave other than just
like a simple fixed voltage/current source.
Exercise
Select another voltage source for the input signal as described above. Change the name
V2 to Veingang.
Right-clicking the icon and
clicking the Advanced button
opens the menu with advanced
settings:
(none) indicates a DC voltage
source.
PULSE is used for square wave
signals with defined rise and fall
times.
SINE is a sinusoidal signal.
Exercise
Set V2 to 1 kHz, 100 mV
amplitude without DC
offset, sine shaped.
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2.6.

Signal names and comments (label, text)

In order to keep the schematic well readable, the lines for the supply voltage are often not
drawn. You simply name corresponding connections using the same expression. This done,
they are automatically connected to each other.
(Edit => Label Net) names a circuit connection (a circuit node)
Exercise
Place a label with the name "supply" on the + terminal of the voltage source Vsupply, on
the + supply of the operational amplifier and on the upper terminal of the resistor R1.
Put a ground connection to the - terminal of the voltage source Vsupply and to the supply of the operational amplifier.
Proceed analogously for the input voltage.
Label the "input" and "output" nodes too. For the latter you draw a horizontal wire
starting at the top of R3 and ending somewhere to the right of it as done in the example
schematic. Wires are allowed have open endings.
(Edit => Text) for comments, titles, etc.
Exercise
Complete the schematic with a heading.
Your schematic should now look like the one shown at the beginning of chapter 2.

3. Simulation (LTspice Dot Commands)
You can use the previously drawn schematic for the simulation or load the schematic from the
server http://dublin.zhaw.ch/~hhrt/LTspice/Vorverstaerker.asc

3.1.

Operating point (DC Operating Point)

Before doing any further simulations (or measurements), it is worth checking that the so called
DC operating point is correct.
For the operating point calculations, capacitors are considered as interruptions (current = 0) and
inductors (used in an example further below) as short circuits (voltage = 0).
(Simulate => Run) opens this dialog window

Click on the register DC op pnt and OK
shows the result of the calculations (all
node voltages and currents).
LTspice introduction.docx
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Where you have specified names for nodes, these are used; the other nodes are numbered by
LTspice.
When the cursor is moved to the node between R1 and R2 in the schematic, the status line
(bottom left) shows:
Or cursor over R1:
Thus, the same information as in the table is also available when you move the cursor to the
corresponding position in the schematic.
Important: You have to re-run your simulation after each change within the circuit, as
minor it may be, otherwise results shown do not correspond to those of the modified
circuit.
The schematic now contains

. If a text starts with a dot, it is a Spice command.

Exercise
To what voltage is capacitor C2 charged?

3.2.

Transient Analysis (Transient)

Right-click the Spice command

to select a different simulation type.

Select the register Transient and enter 3m (= 3 ms) at Stop Time. The Spice command is now
.
(Simulate => Run) opens an empty diagram window.
Click on the "input" and "output" nodes in the diagram to display the signals.
Exercise
Theoretically, the input signal should be amplified by the factor 1+R3/R4. Check if this is
true.
Note: During the transient analysis, the operating point is calculated first before the signal
sources are switched on. Under certain circumstances this may not be desired. In such a case
one of the options "Start external DC supply voltage at 0V" (startup) or "Skip Initial operating
point solution" (uic) should be selected in the simulation command.

3.3.

Frequency Response (AC Analysis)

Adjust the simulation command as follows
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Note: Octave corresponds to a frequency doubling, Decade to a tenfold increase
The schematic now says
(Simulate => Run) shows a window with the error message

This means that you still have to specify which source should be used as input.
Right-click on the source Veingang and enter a 1 (= 1 V) on the right side at

(Simulate => Run) click in the schematic on the nodes "output".
Exercises
What is the gain and phase shift at 10 kHz? The gain is shown in the pseudo-unit dB
(decibel): Gain in dB = 20 · log10 (Gain), Gain = 10Gain in dB/20
Where are the lower and upper cut-off frequencies (3 dB drop)?

3.4.

Transfer characteristic (DC sweep)

To simulate the dependence of the operating point on the supply voltage, change the simulation
command to

Exercise
How does the operating point change with the supply voltage?
DC Sweep can be used nicely for plotting characteristics, i.e. the voltage-current dependance of
a selected basic component.
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4. Diagrams (Waveform Viewer)
To illustrate the possibilities of the evaluations and diagrams, the example of a clocked buck
converter is used. As for the first example, you do not have to know anything about this circuit to
be able to follow the next steps.

You can draw the schematic of the circuit yourself or load it from the server
http://dublin.zhaw.ch/~hhrt/LTspice/Abwaertswandler.asc
Note: In clocked circuits, there is no stable operating point. Therefore the option "Skip Initial
operating point solution" (uic) was selected here. Otherwise, LTspice would try to find the
noexistent operation point and keep on calculating forever.

4.1.

Curve selection (Data Trace Selection)

Run the example. After the simulation results are available, curves can be plotted.

4.1.1.

Voltage versus ground (potential)
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In the diagram click on the node (lines) from which you want to see the voltage curve with
voltage referenced to ground. In the screenshot you can see the red measurement probe on
the line with the name "last".
Exercise
Plot the voltage at the drain of the transistor (node labeled drain).

4.1.2.

Voltage across an element

If, for example, you are interested in the voltage across the coil Lspeicher, left-click on the
node on the right of the coil (left-click) and keep the mouse button pressed while moving the
mouse to the left of the coil, where you release the mouse button. Alternatively, right-click on
the node to the right of the coil and select Mark Reference (black measuring probe). Leftclick on the node to the left of the coil (red measuring probe) shows the desired differential
voltage V(drain,last) = V(drain) - V(last)

ESC key deletes the reference.
Exercise
Plot the voltages between drain and source and between gate and source of the
transistor.

4.1.3.

Current through a component

Hovering the mouse over a component changes the shape to a current clamp
clicking plots the current.

Left-

Exercise
Plot the drain current.

4.1.4.

Current through a line

Hovering the mouse over a wire and pressing the ALT key at the same time changes the shape
to a current clamp

Left-clicking plots the current.

Exercise
Plot the current on the line to the resistor Rlast.
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4.1.5.

Power

If you move the mouse over a component and press the ALT key at the same time, the shape
changes to a thermometer

Left-clicking plots the curve of the power.

Exercise
Plot the power in the resistor Rlast.

4.1.6.

Add Curve (Add Trace)

With this you are able to plot quantities or expressions that cannot be selected directly with the
cursor.
Right-click in the diagram window => Add Trace
For example, to plot the voltage across the coil,
you can click "V(drain)", type "-" in the field at
the bottom, and click "V(last)" at the top.
Of course, one could have typed "V(drain)V(last)" directly or the equivalent expression
"V(drain,last)".
Or to display the energy stored in the coil (W =
½∙L∙I2), one can type the formula
"1/2*50uVs/1A*I(Lstorage)**2" with ** for the
power function. If the coil is specified with the
correct units (50µH = 50µVs/A = 50µVs/1A) the
axis labeling with µJ is correct too.
Note: All functions: Help => Help Topics =>
Register: Index => Waveform Arithmetic
Exercise
Plot the energy stored in the capacitor Cfilter, which is W = ½∙C∙U2.
Control: If your formula is correct, the unit of measure is µJ.

4.1.7.

Curve selection (Visible Traces)

Right-click into the diagram window => Visible Traces
Individual curves can be selected/deselected with the CTRL key and left-clicking.
Exercise
Plot voltage, current, and stored energy for capacitor Cfilter.
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4.2.

Read out numerical values

The graphical progression of a curve shows instantly whether it qualitatively meets your
expectations. For a more precise analysis, quantitative statements are often needed as well.

4.2.1.

Instantaneous values (Attached Cursors)

Right-click on curve name in the diagram window opens

With Attached Cursor the number of cursors can be selected. With 2 it looks e.g. like this

The cursors are marked with 1 resp. 2 and can be moved with the mouse.
The cursor window shows their positions and the differences.
Exercise
Find the clock frequency from the measurement curve of V(drain).

4.2.2.

Mean, effective value (Average, RMS, Integral)

Pressing CTRL key and left-clicking on curve name in the diagram window on voltage,
current and power of Schottky diode opens these windows
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Note: Calculations are made over the entire visible time range. RMS = Root-Mean-Square, the
second order mean (quadratic mean).
Exercise
What are the three mean values for the period 80µs to 100µs?

4.2.3.

Fourier Analysis (Fourier Component)

Activate Diagram window, then Menu View => FFT opens a dialog where you can select from
which curves the frequency spectrum should be calculated.
Note: From frequency resolution = 1/simulation time it follows that the simulation time must
be chosen relatively long, e.g. 10 to 100 periods of the lowest frequency.

4.3.
4.3.1.

Diagram Settings (Plot Settings)
Set axes manually (Axis Control)

When the mouse is over an axis, a scale appears. Click to adjust it.
Exercise
Adjust the axes as follows

4.3.2.

Clipping (Zooming)

Crops can be selected using the zoom tools
described above.

4.3.3.

or by manually adjusting the axes as

Separate curves (Plot Panes)

With many curves the overview suffers quickly. Right-click in the diagram window => Add
Plot Pane opens an additional diagram.
The curves can be moved from one diagram to the other by dragging the curve label over
with the mouse.
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Exercise
Separate the curves like this

4.3.4.

Save plot settings (Save Plot Settings)

Activate Plot window, then Menu Plot Settings => Save Plot Settings
The settings can be reloaded with Plot Settings => Reload Plot Settings.

5. Settings (Control Panel, Color Preferences)
At Tools => Control Panel the following registers are interesting:
SPICE (solver, integration method and accuracy for simulation)
Drafting Options (font size and style, line thickness in the schematic)
Waveforms (font size and style, line thickness in diagram)
With Tools => Color Preferences the colors for schematics and diagrams can be selected.
E.g. I prefer a white background to the default setting black.
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6. Special simulation elements
The SPICE elements can be parameterized in great detail. In addition to the usual mathematical
functions, special "simulation" functions are also available. In other words, SPICE can be used
to simulate almost any electronic circuit, if you knew how.
In this chapter I show some powerful and at the same time simple applications.

6.1.

Simulation without operating point calculation

Usually SPICE first calculates the DC operating point before the transient analysis to determine
the initial values for the simulation. For the operating point calculations, capacitors are
considered as interruptions (current = 0) and inductors as short circuits (voltage = 0).
For clocked circuits e.g., the preliminary operating
point calculation is meaningless, since by
definition some voltages are switched over
quickly.
Skip Initial operating point solution turns on all
sources simultaneously and instantaneously at
the start of simulation.
Start external DC supply voltages at 0V
switches on the DC voltage sources within 20µs
at the start of simulation. This prevents current
peaks during the initial charging of capacitors.

6.2.

Initial Values (.ic = Set
Initial Conditions)

Often, transient processes take a relatively long time and require a correspondingly large
amount of simulation time.

It is much faster to set reasonable initial values for node voltages (for capacitors) and for coil
currents with which the simulation should start.
Reasonable initial values can be obtained from a one-time long simulation, from given boundary
conditions or specifications.
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With the SPICE command
the simulation starts with a current of
2.5A through the coil Lstorage and with a voltage of 5.6V at the capacitor Cfilter.
Note that neither Skip Initial operating point solution nor Start external DC supply voltages
at 0V must be selected in the .tran simulation command if initial conditions are to be
considered.

6.3.

Compare circuit variants

If you want to compare the behavior for different component values, you have to configure the
components accordingly using SPICE commands and parameters. Some frequently used
elements are presented here.

6.3.1.

Parameterize voltage source

For example, to see how the buck converter behaves at different supply voltages, one must
parameterize the source Vspeed. Two steps lead to the result.
Right-click on the source Vspeisung
and enter as DC value [V]: {supply}.
The curly braces {...} mean that the
expression will not be evaluated until
simulation time. supply is an arbitrary
name you decide to use.
To define what
the expression
command in
(Edit =>

is to be done with
supply, place this
the schema with
SPICE Directive)

.step is the command; param is
followed by the parameter name,
from 5 to 20 with step size 5

Here are the simulation results, presented in two ways:
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The diagram on the right with the separated curves is definitively clearer, i.e. always think of
how to arrange plots rather than using the default plotting.

6.3.2.

Parameterize pulse width

For example, to see how the downconverter behaves at different pulse widths, you have to
parameterize the source Vsteuer. The procedure is analogous to the example above. Two steps
lead to the result
•

Right-click on the Vsteuer source and enter {ton} for Ton [s].

•

with

(Edit => SPICE Directive) add to schema

In the upper diagram, only the curves of step 1 were selected; in
the middle, those of step 2 and in the lower, those of step 3.
To view the curves from step 1 in the top diagram, right-click on
the top diagram and select Select Steps
It is important to uncheck Apply to All Panes at the bottom of
the dialog window.
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6.3.3.

Parameterize resistance

The procedure is exactly the same as described for the voltage source.
E.g. compare different load resistors

6.3.4.

Potentiometers

are formed with the help of two resistors
parameterized in opposite directions.

position
Rtop
Rbottom

0

0.2

0.4

0.6

0.8

1

10001Ω

8001Ω

6001Ω

4001Ω

2001Ω

1Ω

1Ω

2001Ω

4001Ω

6001Ω

8001Ω

10001Ω

To exclude a possible division by 0 during the simulation, 1 Ω is added to each resistor.

6.4.

Changes in function of time

How does the behavior change when the load or signal changes? An element in the circuit
can be told that a value changes in the course of the simulation by continuously recalculating it
using the SPICE functions and the variable time. Some frequently used elements are
presented here.

6.4.1.

Timed voltage sources

are already available as a standard in SPICE. All you have to do is select PULSE, SINE or PWL
as the source function.
Take notice of the parameters delay (activate signal delayed) and Ncycles (deactivate signal
after a desired number of periods) which may come in handy.

6.4.2.

Timed current source (as load)

To investigate the control behavior, a current source is often used as a load instead of a
resistor. For example, the reaction to a load step is interesting.
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The procedure is analogous to that
described for the time-controlled
voltage source.
Example:
Current during 50µs 1A, then for
20µs 3A and again 1A with
repetition every 40µs
If you select "This is an active
load", it is guaranteed that the
source behaves as an active load.
I.e. at voltages ≤ 0 the current = 0.

6.4.3.

Timed resistance

Illustration based on an example:
For the step-down converter, the resistance Rlast should be 5Ω during 300µs and 3Ω
afterwards.
The resistance value must therefore be described by a formula with time as a variable.
Right-click on the value of the resistor Rlast
and enter R={5 - 2*u(time - 300u)}.

The function u stands for unit-step: u(x) = unit step, i.e., 1 if x > 0, else 0.
With the variable time = simulation time, the resistance values are calculated as follows
time ≤ 300µs => R = 5 - 2*0 = 5Ω and time > 300µs => R = 5 - 2*1 = 3Ω

Hint:
You can find the available functions in Help => Help Topics => Register: Index => .PARAM

6.4.4.

Timed switch

Time-controlled switches do not exist as a SPICE element. They are often implemented with a
voltage-controlled switch and a voltage source with desired timing.
Instead, it seems simpler to me to use a time controlled resistor (description see above) with a
large (switch open) and small (switch closed) value.
Example: A "switch" which closes after 10ms: Resistance is
first 1MΩ and "switches" after 10ms to 1mΩ.
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6.5.

Transformers

are somehow hard to get running in LTspice. Here is a tutorial: Using Transformers in LTspice
http://www.analog.com/en/technical-articles/using-transformers-in-ltspice-switcher-cadiii.html

6.6.

Accelerate simulation

Depending on the circuit and the input signal, the calculations may converge slowly.
Accelerate convergence with:
•

In the Tools => Control Panel menu, click on the SPICE tab and select Alternate for
Solver.

•

If this is not enough, Abstol: 1e-011 and Reltol: 0.01 can be set additionally, also in the
SPICE register.

7. Help and tutorials
There is an official LTspice Getting Started Guide (slides 14 - 38) in English:
http://www.analog.com/media/en/simulation-models/spice-models/LTspiceGettingStartedGuide.pdf

Mathis Nussberger has written a German short tutorial
http://dublin.zhaw.ch/~hhrt/LTspice/LTSpice%20Tutorial%201%20V03.pdf and for advanced
users a tutorial for including additional Spice models
http://dublin.zhaw.ch/~hhrt/LTspice/LTSpice%20Tutorial%202.pdf
I often use the LTspice internal help (F1 key).
Additionally there is a detailed German tutorial http://www.gunthardkraus.de/LTSwitcherCAD/CD_LTSwitcherCAD/pdf-file/LTspice_4_d.pdf.
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